Displaying FRR Routing and Debug Information for vRouters
This feature provides a new vRouter command to display the output of an IP Stack FRR (Free Range Routing) and debug information from the Netvisor ONE command line interface(CLI).
CLI (network-admin@Spine1) > vrouter-vtysh-cmd
vrouter-vtysh-cmd |
Specify the vRouter FRR command. |
name name-string |
name of service config. |
cmd cmd-string |
any FRR show/debug/undebug/no debug/clear ip/clear ipv6 command. |
Show Output Examples
CLI (network-admin@Spine1) > vrouter-vtysh-cmd name vr1 cmd "show ip route"
Codes: K - kernel route, C - connected, S - static, R - RIP,
O - OSPF, I - IS-IS, B - BGP, P - PIM, A - Babel,
> - selected route, * - FIB route
C>* 100.1.1.0/24 is directly connected, eth1.100
C>* 127.0.0.0/8 is directly connected, lo0
CLI (network-admin@Spine1) > vrouter-vtysh-cmd name vr1 cmd "show running-config"
Building configuration...
Current configuration:
!
frr version 7.2-pluribus
frr defaults traditional
hostname switch
log file zebra.log
log timestamp precision 6
log file bgpd.log
!
enable password zebra
password zebra
!
router-id 1.1.1.7
!
router bgp 650033
bgp router-id 1.1.1.7
coalesce-time 1000
bgp bestpath as-path multipath-relax
bgp prefer nh-global
neighbor 18.18.18.2 remote-as 650033
neighbor 10.10.50.129 remote-as 65001
neighbor 10.10.60.129 remote-as 65002
!
address-family ipv4 unicast
redistribute connected
neighbor 18.18.18.2 next-hop-self
neighbor 10.10.50.129 allowas-in
neighbor 10.10.50.129 weight 200
neighbor 10.10.60.129 allowas-in
neighbor 10.10.60.129 weight 200
maximum-paths 16
exit-address-family
!
address-family ipv6 unicast
redistribute connected
maximum-paths 16
exit-address-family
!
line vty
!
end
For this feature, only show commands are allowed as legal values in the CLI. For example,
CLI (network-admin@switch) > vrouter-vtysh-cmd name vr1 cmd "config t"
vrouter-vtysh-cmd: Illegal value for "cmd"
vrouter-vtysh-cmd: Legal values: commands starting with show, in quotes